Please use english language
It is currently 21 Sep 2017, 05:08

All times are UTC





Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: 25 Aug 2017, 02:34 
Offline

Joined: 22 Aug 2017, 00:41
Posts: 2
Video card: GTX 1070 w/ 8GB of VRAM
Nvidia driver: v385.41
OS: Windows 10 64-bit version
DirectX10 (not 9)
ENB: v.315
Game: Skyrim

For the last month I have been trying without success to make ENB run with Skyrim. When the file d3d9.dll is not present in the game folder, Skyrim runs as expected. As soon as the file is added, I get a black screen on startup and then about four seconds later Skyrim crashes to desktop.

There is a slight difference when I start the game logged on as the built-in user "Administrator". Then I see the initial splash screen that says BETHESDA in large characters and in the upper-left corner I see the information "ENB v.315" and an indication that ENB recognizes GTX 1070 as the video card. A few seconds later the game CTD's.

It puzzles me that I don't see this screen when I logon as user "Owner" (the owner of the game), since Owner has administrator privilege. It caused me to laboriously check that all the files in the Skyrim download are in fact owned by Owner. They seem to be. Since the game crashes with either logon, this discrepancy doesn't seem to provide a clue. (Did I choose an option to skip the BETHESDA screen somewhere?)

Some other things I have tried:

1. Installed four different ENB presets. None worked. I finally realized the problem is not with any particular preset. At present I am using the files that came with the ENB v.315 distribution, Wrapper Version. I am sure I installed this correctly since I have done basically the same thing so many times before. (enbhelper.dll was copied to enbseries folder.)

2. Uninstalled GeForce Experience and backed off the graphics driver to v373.06 (from Oct 2016). It didn't work. Restored driver.

3. Backed off ENB to v.236 (I think) because one of the presets came from that time period and the install instructions referred to it. Grasping at straws. It didn't work. Restored ENB v.315.

4. Removed all mods and tried to run. It didn't work.

5. Uninstalled Skyrim and did entirely new download. That didn't work either.

6. Replaced enblocal.ini with the one from ENBoost 6.1. It doesn't help. I won't list this file, since it is available online. (Is enblocal.ini the only effective file in ENBoost 6.1?)

A listing of SkyrimPrefs.ini is given at the end of this letter, in case someone can see something there.

7. Disabled UseDefferedRendering (deferred has one 'f', btw). It didn't work.

8. Enabled SKSE diagnostics. The last line in skse_steam_laucher.log is: calling winmain.

9. Ran vramsizetest. DX9 version shows 4096 MB. I have not altered any of the predefined memory sizes in enblocal.ini

10. Device Manager shows two "display adapters": Intel HD Graphics 630 and
NVIDIA GeForce GTX 1070

I presume the Intel driver is a built-in fallback driver for when you update or remove the NVidia driver. Could it be causing a problem?

11. Wasted hours combing through myriad .ini files, looking for something to make ENB run. If Skyrim has any diagnostic output at all, I cannot find it. This is frustrating as hell for me as a programmer.

I spent over $1600 for this powerful new computer, largely so I could run Skyrim with ENB. Some people on this forum have reported that the GTX 1070 card works just fine on their rigs, but on mine --- NOTHING WORKS! I started my latest player character when I bought this machine and by now it is nearly at level 40, making me reluctant to continue the game any further. To say the least I am very disappointed with this whole situation.

--- SkyrimPrefs.ini:

[General]
fBrightLightColorB=1.0000
fBrightLightColorG=1.0000
fBrightLightColorR=1.0000
iStoryManagerLoggingEvent=-1
bEnableStoryManagerLogging=0
[Imagespace]
bDoDepthOfField=1
iRadialBlurLevel=2
[Display]
iBlurDeferredShadowMask=3
fInteriorShadowDistance=3000.0000
fShadowDistance=8000.0000
iShadowMapResolutionSecondary=1024
iShadowMapResolutionPrimary=2048
iShadowSplitCount=2
iMaxAnisotropy=16
fLeafAnimDampenDistEnd=4600.0000
fLeafAnimDampenDistStart=3600.0000
fTreesMidLODSwitchDist=10000000.0000
fGamma=1.0000
fDecalLOD2=1500.0000
fDecalLOD1=1000.0000
fSpecularLODStartFade=2000.0000
fShadowLODStartFade=200.0000
fLightLODStartFade=3500.0000
iTexMipMapMinimum=0
iTexMipMapSkip=0
iWaterMultiSamples=0
iMultiSample=8
iShadowMode=3
bTreesReceiveShadows=0
bDrawLandShadows=0
bFull Screen=1
iSize H=1080
iSize W=1920
fMeshLODFadePercentDefault=1.2000
fMeshLODFadeBoundDefault=256.0000
fMeshLODLevel2FadeTreeDistance=2048.0000
fMeshLODLevel1FadeTreeDistance=2844.0000
fMeshLODLevel2FadeDist=10000000.0000
fMeshLODLevel1FadeDist=10000000.0000
iScreenShotIndex=2
bShadowMaskZPrepass=0
bMainZPrepass=0
iMaxSkinDecalsPerFrame=25
iMaxDecalsPerFrame=100
bFloatPointRenderTarget=0
sD3DDevice="NVIDIA GeForce GTX 1070"
bFXAAEnabled=0
iShadowMapResolution=4096
fShadowBiasScale=0.1500
iShadowMaskQuarter=4
iAdapter=0
iPresentInterval=1
iShadowFilter=3
bShadowsOnGrass=1
bTransparencyMultisampling=0
bDeferredShadows=1
bDrawShadows=1
[Grass]
b30GrassVS=0
fGrassStartFadeDistance=7000.0000
fGrassMaxStartFadeDistance=7000.0000
fGrassMinStartFadeDistance=0.0000
[MAIN]
bGamepadEnable=1
bCrosshairEnabled=1
fHUDOpacity=1.0000
bSaveOnPause=1
bSaveOnTravel=1
bSaveOnWait=1
bSaveOnRest=1
fSkyCellRefFadeDistance=150000.0000
[GamePlay]
bShowFloatingQuestMarkers=1
bShowQuestMarkers=1
iDifficulty=2
[Interface]
bDialogueSubtitles=0
bGeneralSubtitles=0
fMouseCursorSpeed=1.0000
bShowCompass=1
[Controls]
fGamepadHeadingSensitivity=1.0000
fMouseHeadingSensitivity=0.0125
bAlwaysRunByDefault=1
bInvertYValues=0
bGamePadRumble=1
bMouseAcceleration=1
bUseKinect=0
[Particles]
iMaxDesired=750
[SaveGame]
fAutosaveEveryXMins=15.0000
[AudioMenu]
fAudioMasterVolume=1.0000
fVal7=1.0000
uID7=0
fVal6=1.0000
uID6=3954
fVal5=1.0000
uID5=285628529
fVal4=1.0000
uID4=285214813
fVal3=1.0000
uID3=94881
fVal2=0.4000
uID2=466532
fVal1=1.0000
uID1=554685
fVal0=0.8000
uID0=1007612
[Clouds]
fCloudLevel2Distance=262144.0000
fCloudLevel1Distance=32768.0000
fCloudLevel0Distance=16384.0000
fCloudNearFadeDistance=9000.0000
[TerrainManager]
fTreeLoadDistance=75000.0000
fBlockMaximumDistance=250000.0000
fBlockLevel1Distance=70000.0000
fBlockLevel0Distance=35000.0000
fSplitDistanceMult=1.5000
bShowLODInEditor=0
[NavMesh]
fObstacleAlpha=0.5000
fCoverSideHighAlpha=0.8000
fCoverSideLowAlpha=0.6500
fEdgeFullAlpha=1.0000
fEdgeHighAlpha=0.7500
fEdgeLowAlpha=0.5000
fTriangleFullAlpha=0.7000
fTriangleHighAlpha=0.3500
fTriangleLowAlpha=0.2000
fLedgeBoxHalfHeight=25.0000
fEdgeDistFromVert=10.0000
fEdgeThickness=10.0000
fPointSize=2.5000
[Trees]
bRenderSkinnedTrees=1
uiMaxSkinnedTreesToRender=20
[Decals]
uMaxDecals=1000
bDecals=1
bSkinnedDecals=1
uMaxSkinDecals=100
uMaxSkinDecalsPerActor=60
[LOD]
fLODFadeOutMultObjects=15.0000
fLODFadeOutMultItems=15.0000
fLODFadeOutMultActors=15.0000
fLODFadeOutMultSkyCell=1.0000
[Launcher]
bEnableFileSelection=1
bShowAllResolutions=1
uLastAspectRatio=3
[BlurShaderHDR]
bDoHighDynamicRange=1
[BlurShader]
bUseBlurShader=0
[Water]
iWaterReflectHeight=512
iWaterReflectWidth=512
bUseWaterDisplacements=1
bUseWaterRefractions=1
bUseWaterReflections=1
bUseWaterDepth=1


Top
 Profile  
 
Tomoko
PostPosted: 25 Aug 2017, 14:11 
Offline
*sensei*
User avatar

Joined: 02 Aug 2013, 23:06
Posts: 389
Location: New Hampshire, US
New computer with windows 10? Did you install DirectX End-User Runtimes (June 2010)? ENB will crash without it installed.

https://www.microsoft.com/en-us/downloa ... px?id=8109

Give that a shot and see if it solves the problem.

_________________
Intel Core i7-7700K 4.2 GHz // GeForce GTX 1080 Ti // Win10 64 and 32GB Ram // Monitor 2560x1440@144


Top
 Profile  
 
PostPosted: 25 Aug 2017, 16:09 
Offline
*blah-blah-blah maniac*
User avatar

Joined: 27 Dec 2011, 08:53
Posts: 11270
Location: St.Petersburg
The crapware are first culprit, cjeck not just geforce experience, but all kind of software you installed and drivers. For example Razer, Logitek input devices install services whicj hook in to games. MSI, EVGA also do this. Disable windows game explorer, disable xbox something. Disable antiviruses (avast and mcafee seems troubling). You can try to make screenshot of all processes, but i dont know many of them in win10, so can only detect very obvious. Of course directx runtime standalone summer 2010 must be installed. Try without skse, if you are using it or in enblocal.ini disable memory manager by setting false all. Disable steam overlay, all software for screen capturing

_________________
Core i5-4690K 3.5 GHz, 16 Gb ram, GeForce 650 Ti 2 Gb, X-Fi Xtreme Music, WinXP/Win7
I am INFP, not the brutal, godamnit.


Top
 Profile  
 
PostPosted: 26 Aug 2017, 02:23 
Offline

Joined: 22 Aug 2017, 00:41
Posts: 2
Running DXSETUP.exe did the trick! Thank you so much for your help. I knew it was probably something simple, but I would never have gotten it without your help, so thank you again. (Incidentally, DirectX10 appears to contain many of the files I downloaded, so just running DXSETUP alone might be enough.)

I have disabled SpeedHack and UsePatchSpeedhackWithoutGraphics in enblocal.ini as they were giving me red warning lines and I don't think I need a speedup on this machine. (I'm showing 132 fps right now.) If I need any more help I will post here. Thanks once more.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group